• Welcome to TodayPlus Boards v2.

Maximum Execution Time Error in getid3.lib.php

Started by devless, March 12, 2007, 01:53:24 AM

Previous topic - Next topic


Hi Folks!

I installed this SPGM-Vid contribution to make a Video Gallery on my website - awesome addition..
The contribution intially worked, however now I get the following error when trying to view my video gallery (my photo galleries are just fine).
"Fatal error: Maximum execution time of 30 seconds exceeded in /home/xxxxxx/public_html/xxxxxx/getid3/getid3.lib.php on line 237"

The line number that faults is different each time. Is this perhaps a maximum time tweak I need to make in the php config file on my server?
If so, which one?



Do you have a link?

It worked before, for how long?  Did you change anything on your server? Which version of SPGM-Vid and the GetID3() library are you running?
Jim H


Hi there,

Unfortunately I had to remove the gallery from my live site (as I couldn't get it working).

I increased my execution time to up to 120s but it was still timing out on the getid3.lib.php.

I was using the latest version of both SPGM Gallery and SPGM-Vid.

When it was working, was about 5 minutes before it stopped working :). I installed the new code into my website, uploaded it - it worked, I added some new videos to the directories - it stopped working.
I deleted the videos, I started again, I reuploaded the files etc - but couldn't get it working.
It IS working on my test server, but not anymore on the live server.?? (nothing else was changed in the meantime on the live server).


That is odd.

I went to the getid3() forum and nothing stood out that was similar to your problem.  I will post something of there and see if anyone can offer any assistance.

But before I do that, are you hosting on a Windows server?  If so, what version?
Jim H


Hi there, thanks for your response.

I am hosting on a linux server.
PHP: 4.4.4
apache 1.3.37